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Preface
Purpose of this guide
Intended readership

This document is intended for market data or compliance department technicians at financial
companies that have decided to use RMC External Feeds to access Eikon Messenger data
logs in XML format.

Basic definitions

TERM

DEFINITION

Compliance
Setup

A Compliance Setup groups together all Messenger users for a single company or
site. One company can have several Compliance Setups.

External Feeds

The External Feeds solution provides Messenger data logs in XML format. These
logs are available daily for download through FTPS or SFTP. External Feeds are
suitable for Messenger Compliance customers that already have a data archival
environment.

Thin client

Version of Messenger available inside Eikon (as opposed to the stand-alone version
of Messenger).

This table provides basic definitions for terms and concepts used in this guide.

TERM

DEFINITION

Messenger

Eikon Messenger is an instant messaging tool and real-time communication service
for financial professionals.

Content

Content includes instant messages, chat activity, “blasts” to multiple recipients, and
attached files or screenshots.

Messenger
Compliance

Refinitiv Messenger Compliance (RMC) is a hosted service that collects all
conversations and exchanges of information via Eikon Messenger for regulatory
compliance purposes. User activity and related content is reported to RMC for users
that have been compliance-enabled. RMC organizes reported data into compliance
logs which are associated with a specified Compliance Setup, each of which has
a unique RMC ID. RMC is comprised of four components that can be configured
separately or in combination for each Compliance Setup/RMC ID:

In this guide

This document provides all the information you need to download and interpret Eikon
Messenger data logs in XML format. It notably includes:
• An overview of Refinitiv Messenger Compliance and External Feeds
• How to access XML data logs using Secure FTP
• How to interpret XML data logs
• Frequently-asked questions

Prerequisites

Before using this guide, you must have already:

•

RMC Capture

•

RMC Policy Management

• Filled in a Compliance Setup Form and submitted it to the Compliance BizOps team
(compliance.bizops@tr.com)

•

RMC External Feed

• Received log-in details (username and password) for the External Feeds site

•

RMC Hosted Archiving (via Global Relay)

Need more help?

If you have questions or require advice or assistance using External Feeds, please contact the
Compliance BizOps team (compliance.bizops@tr.com).
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Getting to know External Feeds
About External Feeds

For Messenger Compliance customers that already have a data archival environment, the
External Feeds solution provides Messenger data logs in XML format. These logs are available
daily for download through FTPS or SFTP.

External Feeds benefits
• Easy setup

• Automated downloads
• Robust security and resilience features
• Restricted IP Access to the secure XML file store
• Encryption of your files using your company’s public key
• Service offered free of charge

Overview of the External Feeds process

These are the overall steps in the External Feeds process.
1	Submit a Compliance Setup Form to the Compliance BizOps team (compliance.bizops@
tr.com). On this form, you must indicate the time you want daily data logs to be compiled.
i

This time slot must not be between 18:30 and 20:00 GMT.

2	Refinitiv sends you a username and password to access the secure XML file store where
Messenger data logs are stored.
3	Every 24 hours, within six hours of your preferred time slot, Messenger data logs are
exported to the XML file store, and saved in a directory corresponding to the date in
question.
4	Use your username and password to access the XML file store and download the zipped
XML files for each 24-hour period.

4

OR
	You set up an automated download to take place on a daily basis, using an appropriate Secure
FTP tool.
5	Use the summary files to make sure that all content has been downloaded correctly, and
download again if that is not the case.
6

Purge files from the file store after downloading them.
OR
Refinitiv purges files automatically after 30 days.
i	After being purged, files cannot be recovered. The 30-day automatic purge is
only activated once External Feeds is configured and you receive your username/
password to download data.
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Downloading XML data logs
The XML download process

FileZilla is not a Refinitiv product. We present it here as one example of a Secure FTP client for
use with External Feeds.

Messenger content for each Compliance Setup is stored in a separate data log for each 24-hour
period. These data logs are in XML (extensible markup language). For more information about
interpreting the XML used in the data logs, see “Introduction to External Feed XML data” on
page 10.

How to download, install and open FileZilla File Transfer Client

About Messenger content data logs

About the Secure FTP server

Follow these steps to download, install and open FileZilla FTP Client.
1

Download FileZilla Client from https://filezilla-project.org/index.php.

2

Install FileZilla Client following the on-screen instructions.

XML data logs are available on the External Feeds Secure FTP site at feeds.compliance.collab.
thomsonreuters.com. You can retrieve data from the FTPS or SFTP.

3	Open FileZilla by going to Start > All Programs > FileZilla Secure FTP Client and clicking
FileZilla.

About Secure FTP client applications

	FileZilla opens, displaying the local site (your workstation) in the left pane, and the remote
site in the right pane.

To access the External Feeds Secure FTP site, you must use a Secure FTP client application.
SFTP applications are available with most operating systems. Open-source solutions such as
FileZilla also exist. For an example workflow using FileZilla, see “Using FileZilla to download XML
data” on page 5.

How to download XML data logs from the Secure FTP server
To download XML data logs from the FTP server, follow these steps.
1

Go to the site: feeds.compliance.collab.thomsonreuters.com.

2

Log in with your username and password.

3

Locate the data logs you want to download.

4

Copy the data logs to your local workstation.

5

If required, delete the data logs from the Secure FTP site.
i

After deletion, data logs cannot be recovered.

If you are using External Feed IP Restriction feature, you will need to ensure you connect from
the IP address range provided to us on the Client Setup Form.

Using FileZilla to download XML data
About FileZilla

FileZilla is an open-source File Transfer client for Windows®, Mac OS X®, and GNU/Linux. You
can use FileZilla to download the External Feed XML logs to your local server. You can find out
more information about FileZilla by visiting https://filezilla-project.org/index.php.
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How to set up a remote Secure FTP site connection using FileZilla
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3

The first time you use FileZilla, follow these steps to set up the connection to the External Feed
FTP server.
i
1

In Select Entry, click New Site and give your new site a name.
i

For example, type External Feeds store.

You will need your External Feeds username and password.

Open FileZilla (go to Start > All Programs > FileZilla FTP Client and click FileZilla).

2	Go to File > Site Manager.
The Site Manager dialog box appears.

4

In General > Host, type the host name:
feeds.compliance.collab.thomsonreuters.com

5	In General > Protocol and General > Encryption, choose the protocol and encryption
methods you want.
For more information, see “Protocol and encryption methods” on page 7.
6

In General > Logon Type, choose Normal.

7

In User, type the username for your External Feed account.
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In Password, type the password for your External Feed account.

9

Click OK to save your server connection parameters.

OR
Click Connect to save your server connection parameters and to connect immediately to the
External Feeds store.

7

4	When the connection is established, you will see file folders under Remote site. Each
of these folders contains the External Feed logs for your Compliance Setup for a single
24-hour period.
For example, the folder 2019-07-30T0900+0000 contains all log files for a 24-hour period
beginning at 09:00 GMT on July 30, 2019.

Protocol and encryption methods

You can connect to the External Feed store using SFTP or FTPS. This table explains which
Protocol and Encryption settings you must choose in FileZilla for each type of connection.
CONNECTION TYPE

PROTOCOL

ENCRYPTION

SFTP

SFTP – SSH File Transfer Protocol

N/A

FTPS

FTP – File Transfer Protocol

Require explicit FTP over TLS

How to download External Feed logs

After you have set up your Secure FTP connection, you can connect to the External Feed store
and download your XML logs.
1	On your local workstation, make sure you have a destination folder for the XML log files
you want to download.
	For example, create a folder called Compliance Downloads on your local workstation
using Windows Explorer.
2

In FileZilla, open the Site Manager dialog box by going to File > Site Manager.

3	Select the entry for the External Feeds store, and click Connect. Site Manager closes, and
the FileZilla status window displays information about your connection. If If you receive
a warning message about the server certificate, be sure to validate it to connect to the
External Feeds store.
For more information on folder contents, see “Log folder contents” on page 8.
5	Use your mouse to drag the log folder(s) you want to download, then drop them in the
destination folder on your local workstation (under Local site on the left side of the FileZilla
screen).
i
6

The task bar at the bottom of the FileZilla screen indicates the file transfer status.

After you have finished downloading the files, close your Secure FTP connection.
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Log folder contents

Each log folder in the External Feeds store contains all data exchanged over Messenger by
anyone in your Compliance Setup over a 24-hour period. The name of the folder indicates the
date and time when the 24-hour period began e.g., 2019-07-30T0900+0000.
FILE NAME

DESCRIPTION AND CONTENTS

summary.xml

Summary of Messenger activity over the period, including the number of
messages and attachments transferred among users

summary.xml.sha1

Checksum file for summary.xml

messages.zip

All messages transferred among Messenger users during the period
•

This is a compressed file that contains messages.xml.

messages.zip.sha1

Checksum file for messages.zip

attachments.zip

All attachments transferred among Messenger users during the period
•

attachments.zip.sha1

This is a compressed file.

Checksum file for attachments.zip

8

Log folder contents if data encryption is selected

Enhanced security is available through the RMC Policy Management portal where you can
select to use the Data Encryption feature. This allows you to upload your company’s public key
(.pem) that Refinitiv will use to encrypt the files that we make available to you. Once you have
successfully downloaded your files, you can then decrypt them using your company’s private key.
When using data encryption, the log folder in the External Feeds store will now contain
additional encrypted (.enc) and key (.key) files.
Access to the RMC Policy Management portal is not active by default. You can request its
addition to the RMC External Feeds XML via the Compliance Setup Form or by contacting the
Compliance BizOps team compliance.bizops@tr.com.
FILE NAME

DESCRIPTION AND CONTENTS

summary.xml.enc

Encrypted – summary of Messenger activity over the period, including the
number of messages and attachments transferred among users

summary.xml.key.enc

Key – summary of Messenger activity over the period, including the number
of messages and attachments transferred among users

summary.xml.enc.sha1

Encrypted – checksum file for summary.xml

summary.xml.key.enc.sha1

Key – checksum file for summary.xml

FILE NAME

DESCRIPTION AND CONTENTS

messages.zip.enc

reconcile.xml

Reconciliation file for Messenger activity over the period, including the
number of conversations and messages exchanged, as well as the unique
identifiers for each conversation and message

Encrypted – all messages transferred among Messenger users during the
period
• This is a compressed file that contains messages.xml.

messages.zip.key.enc

Key – all messages transferred among Messenger users during the period
• This is a compressed file that contains messages.xml.

messages.zip.enc.sha1

Encrypted – checksum file for messages.zip

messages.zip.key.enc.sha1

Key – checksum file for messages.zip

attachments.zip.enc

Encrypted – all attachments transferred among Messenger users during the
period
• This is a compressed file.

attachments.zip.key.enc

Key – all attachments transferred among Messenger users during the period
• This is a compressed file.

attachments.zip.enc.sha1

Encrypted – checksum file for attachments.zip

attachments.zip.key.enc.sha1

Key – checksum file for attachments.zip

reconcile.xml.sha1

•

This file only appears if the reconciliation feature is activated for the
Compliance Setup.

•

The reconcile.xml document is not active by default. You can request
its addition to the RMC External Feeds XML via the Compliance Setup
Form or by contacting the Compliance BizOps team (compliance.
bizops@tr.com.)

Checksum file for reconcile.xml
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FILE NAME

DESCRIPTION AND CONTENTS

reconcile.xml.enc

Encrypted – reconciliation file for Messenger activity over the period,
including the number of conversations and messages exchanged, as well
as the unique identifiers for each conversation and message
•

reconcile.xml.key.enc

This file only appears if the reconciliation feature is activated for the
Compliance Setup.

Key – reconciliation file for Messenger activity over the period, including the
number of conversations and messages exchanged, as well as the unique
identifiers for each conversation and message
•

This file only appears if the reconciliation feature is activated for the
Compliance Setup.

reconcile.xml.enc.sha1

Encrypted – checksum file for reconcile.xml

reconcile.xml.key.enc.
sha1

Key – checksum file for reconcile.xml

9
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Introduction to External Feed XML data
Interpreting External Feed XML data
About XML format

XML (extensible markup language) is a human-readable and machine-readable format. Several
software applications can read XML format. You can open XML files in a simple text editor or
Web browser, such as Notepad or Microsoft® Internet Explorer®. XML format contains a series
of tags that indicate what kind of data is being displayed. The tags appear in angled brackets <
> and correspond to predefined categories that let you interpret the Messenger content.

Example of External Feed tags

This extract from a summary.xml file includes two tags:
• <FirstEventTime> gives the time stamp for the first event in the log.
• <LastEventTime> gives the time stamp for the last event in the log.
The closing tags, represented as </tag name>, indicate the end of that type of information.
<FirstEventTime>2019-07-29T02:42:40.583Z</FirstEventTime>
<LastEventTime>2019-07-30T01:30:59.000Z</LastEventTime>

Interpreting summary.xml
Example summary.xml file

<?xml version=”1.0” encoding=”UTF-8”?>
<ComplianceActivitySummary>
<Version>1.0</Version>
<FirstEventTime>2019-07-29T02:42:40.583Z</FirstEventTime>
<LastEventTime>2019-07-30T01:30:59.000Z</LastEventTime>
<NumberOfEvents>63</NumberOfEvents>
<NumberOfAttachments>14</NumberOfAttachments>
</ComplianceActivitySummary>

Tags in summary.xml
TAG

MEANING

ComplianceActivitySummary

Simply indicates the start and end of the summary.xml file

Version

Version of the file, usually 1.0

FirstEventTime

Date and time stamp (time in GMT) for the first event that occurred
during the 24-hour period that the log covers

LastEventTime

Date and time stamp (time in GMT) for the last event that occurred
during the 24-hour period that the log covers

NumberOfEvents

Total number of events over the 24-hour period. For more
information on events, see “Interpreting events” on page 12.

NumberOfAttachments

Total number of attachments transferred among Messenger users
over the 24-hour period. For more information on attachments, see
“Interpreting attachments” on page 14.
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Interpreting messages.xml
About messages.xml

The messages.xml file references all Messenger activity in your Compliance Setup over a 24hour period. Depending on the volume of messages exchanged, this file can be very lengthy.
As a reminder, Messenger activity can include:
• A one-on-one conversation between two Messenger users
• A multiparty “chat” among more than two users in a chat room
• Attached files or screenshots shared among users

Main parts of messages.xml
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Definition of header tags
TAG

MEANING

ComplianceSetup

Identifies the Compliance Setup for the present feed

ID

Gives the unique identifier for the Compliance Setup

Name

Gives the name for the Compliance Setup

DatePeriod (From/To)

Indicates the date and time stamps (time in GMT) for the start and
end of the 24-hour period that the log covers

The messages.xml file contains three main parts: headers, users and chats. Each of these parts
contains tags.
MAIN PART

CONTENTS

Header

Information about the specific compliance feed

Users

Information about the user(s) active over the 24-hour period

Chats

A list of Messenger conversations and chats reported in the feed

Example header

A header is introduced with the <headers> tag.
<Headers>
<ComplianceSetup>
<ID>142</ID>
<Name>Investment Company A</Name>
</ComplianceSetup>
<DataPeriod>
<From>2019-07-29T12:00:00.000Z</From>
<To>2019-07-30T12:00:00.000Z</To>
</DataPeriod>
</Headers>

Example users list

A header is introduced with the <headers> tag.
<Users>
<UserInfo>
<Identifier>bob.smith@refinitiv.com</Identifier>
<Email>bob.smith@refinitiv.com</Email>
<FirstName>Bob</FirstName>
<LastName>Smith</LastName>
<ComplianceSetup>
<ID>52</ID>
<Name>Refinitiv (GR)</Name>
</ComplianceSetup>
<SiteLocation>
<ID>SL1+JPBX+36499</ID>
<Name>Refinitiv</Name>
</SiteLocation>
</UserInfo>
<UserInfo>
<Identifier>jane.jones@refinitiv.com</Identifier>
<Email>jane.jones@refinitiv.com</Email>
<FirstName>Jane</FirstName>
<LastName>Jones</LastName>
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Definition of user tags
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Definition of chat tags

TAG

MEANING

TAG

MEANING

UserInfo

Indicates the start and end of information about a single user

Identifier

Unique identifier for the chat

Identifier

Gives the user’s Messenger log in

Topic

Topic (if any) displayed in Messenger for the chat

Email

Gives the user’s email address

Disclaimer

ComplianceSetup

Gives the unique identifier and name of the Compliance Setup that
the user belongs to

Disclaimer (if any) displayed in Messenger for the chat. For more
information on the disclaimer, see “How can I define a customized
disclaimer for all Messenger users in my company’s Compliance
Setup?” on page 17

SiteLocation

Gives the unique identifier and name of the user’s site location

Participants

List of participants in the chat, each introduced with a <User> tag

Events

List of events that represent activity during the chat

Example chats list

For more information on the types of events, see “Interpreting Events”
on page 12

The chats list is introduced with the <chats> tag.
<Chats>
<Chat>
<Identifier>rmchat://room/refinitiv.com/RM_L3_Test5</Identifier>
<Topic> Weekly Trading Community Talks give equities participants unique insight on
market developments from a ringside perspective. </Topic>
<Disclaimer>normal disclaimer applies</Disclaimer>
<Participants>
<User>bob.smith@refinitiv.com</User>
<User>jane.jones@refinitiv.com</User>
</Participants>
<Events>
<Event>
<Type>Join</Type>
<User>bob.smith@refinitiv.com</User>
<UTCTime>2019-07-30T10:00:41.563Z</UTCTime>
</Event>

Interpreting events
Types of events

In messages.xml, an event represents any activity within the Compliance Setup. For example, a
new participant joining a conversation constitutes an event. Each event is indicated separately
and time-stamped. Types of events are:
• Join
• Leave
• Send
• HistoryRequest
• TopicChange
• DisclaimerChange
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Example event log

In this extract, there are two events: join and history request.
• Join indicates that a new participant has joined a conversation. The user’s name and the
time stamp appear in the <User> and <UTCTime> tags.
• History request indicates that when a user joins a chat room, Messenger displays the 50 most
recent messages in the chat room so that the user can know what the conversation is about.
The user can request additional history by clicking View conversation history in Messenger
(or by scrolling up in Eikon Messenger). Each scroll or click recovers more history in batches
of 50 messages. The <HistoryRequest> tag is followed by the user that triggered this event,
the time stamp and a series of <Message> tags with all the messages exchanged previously.
<Event>
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Definition of event type tags
TAG

MEANING

Join

New participant joins a conversation or chat room

Leave

Current participant leaves a conversation or chat room

Send

Participant sends a new message to one or more participants (followed by
<Message> and related tags on the content being sent)

HistoryRequest

Automatically generated when a participant joins a multiparty chat room,
and also generated when a participant browses backward in the chat
history (by scrolling up or clicking View conversation history). With each
history request, Messenger displays the 50 previous messages in the
chat room. This tag is followed by <Message> and time-stamped tags for
each message exchanged.

TopicChange

Indicates a new or updated topic for the discussion

DisclaimerChange

Indicates a new or updated disclaimer displayed on the user’s screen

<Type>Join</Type>
<User>bob.smith@refinitiv.com</User>
<UTCTime>2019-07-30T03:13:59.433Z</UTCTime>
</Event>
<Event>
<Type>HistoryRequest</Type>
<User>bob.smith@refinitiv.com</User>
<UTCTime>2019-07-30T03:14:02.307Z</UTCTime>
<Message>
<MessageID>125160232</MessageID>
<User>lee.hamilton@refinitiv.com</User>
<UTCTime>2019-07-30T10:00:41.563Z</UTCTime>
<Content>let’s check the p/e on that stock</Content>
</Message>

Refinitiv | Refinitiv Messenger Compliance External Feeds User Guide

Interpreting attachments
About attachments

Whenever a Messenger user sends an attachment, a reference appears in the messages.xml
file. This generates two log files stored in attachments.zip:

14

Example attachments.zip content

In the attachments.zip file for the same period, we can see the attachments that Sarah sent,
using the names indicated in messages.xml:

• An XML file that gives the attachment in XML format
• A copy of the attachment
i

M
 essenger renames all attached files so that each has a unique identifier. The new
names allow you to see attachments in chronological order.

Example file attachment log

In this extract, the user Sarah Johnson sends a single message with two attached files using
Messenger, each indicated with a <FileAttachment> tag in messages.xml:
• The first attachment is a screenshot called Screenshot.png. It is referenced under the name
1.xml in the attachments.zip file.
• The second attachment is an Eikon desktop file called DesktopObject.xml. It is referenced
under the name 2.png in the attachments.zip file.
<Message>
<MessageID>125672475</MessageID>
<User>sarah.johnson@refinitiv.com</User>
<UTCTime>2019-07-30T04:47:53.637Z</UTCTime>
<Content> 1.xml 2.png </Content>
<FileAttachment>
<Reference>1.xml</Reference>

Definition of file attachment tags
TAG

MEANING

Content

File names of the attachment(s) in attachments.zip

FileAttachment

Indicates information for a single file attachment

Reference

File name of the attachment in attachments.zip

Name

File name as it appears to the Messenger users
i

<Name>Screenshot.png</Name>
<HyperlinkName>Screenshot.png</HyperlinkName>
</FileAttachment>
<FileAttachment>
<Reference>2.png</Reference>
<Name>DesktopObject.xml</Name>
<HyperlinkName>DesktopObject.xml</HyperlinkName>
</FileAttachment>
</Message>

Hyperlink

M
 essenger changes this name to Reference when storing the
attachment in the log file

Hyperlink text used when transferring the file. (In Messenger, a recipient
clicks on a hyperlink to download and view an attachment.)
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Reconciling External Feeds data
About reconciliation

Reconciliation is an additional feature that lets you check the number of messages exchanged
over Messenger and their unique identifiers. It is especially useful if a third-party provider
“ingests” your XML content to supply you with a searchable database. With reconciliation,
you can ensure that all messages exchanged over a given period are in the database, no
messages were lost and your organization is compliant with record-keeping rules.

How to activate reconciliation

The reconcile.xml document is not active by default. You can request its addition to the RMC
External Feeds XML via the Compliance Setup Form or by contacting the Compliance BizOps
team (compliance.bizops@tr.com).

Example reconciliation.xml file

15

Tags in reconciliation.xml
TAG

MEANING

Reconcile

Simply indicates the start and end of the reconciliation.xml file

Version

Version of the file, usually 1.0

Chats count

Number of conversations (or “chats”) during the 24-hour period covered
in the file

Chat

Indicates the start and end of a single conversation

Identifier

Unique identifier for the conversation

This example shows a simple reconciliation file. You can use this file to reconcile messages.xml
with any processed version of the file. The chat count and message count parameters let you
check that all conversations and messages were processed, and unique identifiers help you find
any missing messages.
<?xml version=”1.0” encoding=”UTF-8”?>
<reconcile>
<Version>1.0</Version>
<Chats count=”2”>
<Chat>
<Identifier>29edwnjewii39</Identifier>
<Messages count=”3”>
<MessageID>2526588520</MessageID>
<MessageID>2526588521</MessageID>
</Messages>
</Chat>
<Chat>
<Identifier>dht48dn9k4nm</Identifier>
<Messages count=”2”>
<MessageID>3be6cc4b-3063-4179-b317-df67445d8631</MessageID>
<MessageID>7a7b206a-c827-4c9c-ae73-496975cfd0b7</MessageID>
</Messages>
</Chat>
</Chats>
</reconcile>

i	
These identifiers are randomly generated, so they are unique
for a given period and Compliance Setup, but identifier
numbers could be duplicated in other periods or Compliance
Setups.
Messages count

Number of messages exchanged during the conversation. These
messages only include new messages sent by a user. They do not
include duplicate messages (“history request”) displayed when a user
enters a conversation (see “HistoryRequest” on page 13).

Message ID

Unique identifier for the message
i	
These identifiers are randomly generated, so they are unique
for a given conversation, but message ID numbers could be
duplicated in other conversations.
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Frequently asked questions
Setting up External Feeds

Will I receive details to access the Secure FTP site by email?

Can https protocol be used in External Feed?

Are there any guidelines for selecting the delivery time, for example, end
of the business day?

What are the security measures for your External Feed?

The log in credentials (username and password) to access the External Feeds Secure FTP site
will be sent by email after your Compliance Setup Form has been processed.

When you fill in the Compliance Setup Form, you can indicate the time slot for daily XML
data logs. We make every effort to satisfy your request. Please note that data logs cannot be
delivered between 18:30 and 20:00 GMT. Data logs are available on the Secure FTP site within
six hours of the designated time. If you do not choose a specific time, we will assign one and
inform you in the email with your log in credentials.

Are the XML data logs delivered daily? If not, what is the frequency?

One XML data log is generated for every 24-hour period and available on the Secure FTP site
for you to download.

Is it possible to receive the XML data log once every month?

Each XML data log covers a 24-hour period. Logs are available on the Secure FTP site for a
period of 30 days before deletion. However, logs are not provided in a compiled weekly or
monthly format.

Accessing the Secure FTP site and downloading files

Is it possible to have your XML file sent directly to our own Secure FTP site
rather than collecting it from your Secure FTP site on a daily basis?
No, we do not currently offer this service.

Do you offer data encryption of the files in the External Feed store?

Enhanced security data encryption is available as standard and customers can “opt in” by
uploading a public PEM file by using the Policy Management portal. The encrypted External
Feed log files can be collected and decrypted by your private key.

No, we do not currently offer this service. However, you can download logs using a secure
connection.
A number of checks are in place to ensure that the data and communication is secure at all
times, notably:
• All communication between the File Transfer client and server is secured using a SSL/TSL
based connection (FTPS) or SSH (SFTP).
• User is authenticated with a password and directed to the appropriate folder location
within the file system. A user is only authorized to access compliance files for their own
Compliance Setup.
• A strong password is required for every user to minimize the risk of unauthorized access.
• Firewalls are configured to allow only appropriate traffic to FTP servers and to block any
direct external traffic to the file store.
• In the event of a failed log in, there is a five-second delay to limit the possibility of brute force
attacks.
i

F
 or more information on security, see the Security Overview of the Eikon Messenger
Service.

Are the logs delivered just through the Secure FTP site?
Logs are available only through FTPS or SFTP.

Is the data encrypted?

Yes, 128-bit SSL/TLS encrypted channels are used. See “Protocol and encryption methods” on
page 7.

Can IP filtering be applied to allow only customer’s identified IP address?
Yes.

Why are some files missing from the log folder?

Message and attachment files (messages.zip and attachments.zip) do not appear if there were
no messages or attachments transferred over the period covered in the log folder.
The reconciliation file (reconciliation.xml) only appears if reconciliation is active for your
Compliance Setup.
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Interpreting XML content

Support and miscellaneous

Yes. In addition to the sample extracts in this guide, we can provide sample XML files to allow
you to test your setup for retrieval and display of XML logs. Please contact the Compliance
BizOps team at compliance.bizops@tr.com.

Please contact the Compliance BizOps team at compliance.bizops@tr.com.

Do you have information regarding the XML format?

What are “events” in the XML log?

In the XML log, an “event” represents activity within the Compliance Setup. An event is one of
the following types:
• Join
• Leave
• Send
• HistoryRequest
• TopicChange

Who should I contact for support on the External Feed?

Who should I contact for support on the Data Encryption and access to the
RMC Policy Management portal?
Please contact the Compliance BizOps team at compliance.bizops@tr.com.

How can I define a customized disclaimer for all Messenger users in my
company’s Compliance Setup?

Disclaimers delivered in IM conversations and recorded as part of a compliance transcript can
be defined in the RMC Policy Management portal. Additionally, disclaimers can be customized
on a per-chat room basis through the Messenger application itself. For more information,
please contact the Compliance BizOps team at compliance.bizops@tr.com.

Can I have a sample of logs delivered by External Feed?

• DisclaimerChange

Yes, these are available on request to compliance.bizops@tr.com.

For more information, see “Types of events” on page 12.

Can users enabled for RMC Capture only obtain historical data via an XML
feed on a one-off basis?

Which programs can I use to view an XML file?

You can view the XML file contents with a simple text editor such as Notepad or a Web browser
such as Microsoft Internet Explorer.

Who supports/ingests your XML?
• 17a-4 Data Parser

• Actiance Vantage
• Globanet Merge1
• VerQu
• Behavox
• Proofpoint
• Smarsh
• Winco Talk Manager

How can I see if a file attachment has been sent during a Messenger
conversation?

Whenever a Messenger user sends a file attachment, the <FileAttachment> tag appears in
the XML log. The <Name> tag indicates the name of the attached file. All attached files are
included in the attachments.zip file for that day’s log.

No, External Feeds is a going-forward implementation only.

Are screenshots and hardware/software/network minimum requirements for
archiving XML messages on customer site available?
No. Hardware, software, and system requirements vary depending on the application used to
process the XML feeds, the number of users in your compliance setup and the volume of data
exchanged over Messenger. Third-party vendors (who support the Refinitiv XML) can provide
further information regarding the setup and system requirements of their solutions.

Is it possible to extract conversations of one date in the past via an
XML feed?

XML logs are available for the past 30 days, so you can extract conversations from any day in
the past month. However, after 30 days, the log files are purged and irretrievable. Therefore,
we recommend that you set up an automatic daily download of log files to archive them on
your own servers. (Note: the 30-day purge only takes effect after External Feeds is configured
and you receive your username/password.)
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