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About this document
In this section
•
•
•
•

Intended readership
Target audience
Prerequisite knowledge
Conventions used in this guide

Intended readership
This document is intended for Refinitiv Eikon users who are installing the application themselves. Users are
presumed to have a basic level of computer knowledge.

Target audience
Follow the procedures in this chapter if you are:
•

a user installing Eikon at home or in a small office

•

an IT specialist installing Eikon on a small number of PCs

Prerequisite knowledge
You are required to have a basic level of computer knowledge to successfully install Eikon.

Windows operating system
•

Use Windows Explorer to navigate to any specified folder on any fixed or removable drive on your system

•

Perform file management tasks such as creating and deleting folders, and copying, moving, and deleting files

•

Close or disable all applications running in the background

•

Use the Help menu or F1 key within an application to find a solution to a problem and learn how to use
functions and features

•

Install and uninstall software

Internet
•

Download and save files from the Internet to your computer

•

Send attachments by email and save attachments received in email messages

•

Open web pages in new browser tabs or windows

Conventions used in this guide
Text formats
Different text formats are used to indicate commands, menu items, and so on.
Convention

Explanation

Ctrl + a, Apply

Menu names and items, command buttons, and key combinations
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Convention

Explanation

Hyperlink

Cross references and external links

courier font

User input, directories, file names, and so on, that you must enter exactly as shown

<courier_italics>

Site or user-specific variables or parameters

File > New

Sequence of menu items to choose
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Terminology
Different terms indicate user actions.
Term

What You Do

Select

Place the cursor over the item and click to make a choice in a radio/check box.

Choose

Make a choice from two or more available menu items.

Click

Quickly press and release the mouse button while the cursor is over the item.

Double click

Quickly press and release the mouse button twice in succession while the cursor
is over the item.

Drag and drop

Press and hold the mouse button while the cursor is over the item, then move
the cursor to the required position, and then release the mouse button.

Enter

Type in data.

Highlight

Place the cursor over a row in a table (or a cell in a matrix) and quickly press
and release the mouse button while the pointer is over the item.

Press

Press a key on your keyboard.
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Installation and software updates
In this section
•
•

Installing and updating Eikon
Getting assistance with installations and updates

Installing and updating Eikon
Verifying hardware and software requirements
Before installing Eikon, ensure that your hardware and software meet requirements. For more information, see:
•

Refinitiv Eikon PC Requirements1

•

Refinitiv Eikon System Test Guide2
 Alternatively, click the question mark icon next to each test result to view the steps you must take to
resolve the issue.

Installing from email
Follow these steps to access installation from the Welcome Email message.
1.

Locate your Welcome Email.
 To quickly find the message in your email application, search for customerzone@refinitiv.com in the
sender field and/or Welcome to Refinitiv Eikon in the subject line.

2.

Follow the instructions in the Welcome Email to access Eikon, then go to How do I complete the installation?.

Installing from the website
If the Welcome Email message is not available, follow these steps to access installation from the Internet.
1.

2.

Go to the Eikon website:
o

https://eikon.refinitiv.com/ or

o

For private network users only, http://eikon.extranet.refinitiv.biz/

Click Sign in & Download, then go to How do I complete the installation?.

Completing the installation
Follow these steps to complete installation.
1.

Follow the instructions in your web browser to:
a.

accept the licensing agreement

b.

choose the country where you are usually located

c.

set your password

d.

create your profile

1

https://my.refinitiv.com/content/dam/myrefinitiv/products/9622/en/Technical/613695.pdf

2

https://my.refinitiv.com/content/dam/myrefinitiv/products/9622/en/Technical/555409.pdf
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download the Installer.exe file

2.

Run EikonInstaller.<REGION>.exe, where <REGION> is APAC1, EMEA1, AMERS1 or AMERS2.

3.

Install the software in the default folder.

Locating installation files
The default location of the software depends on whether you installed the software when logged in as
administrator.
Rights

Path

Administrator

64-bit OS

%programfiles(x86)%\Thomson Reuters\Eikon

32-bit OS

%programfiles%\Thomson Reuters\Eikon

Non-Administrator

%userprofile%\Thomson Reuters\Eikon

Installing add-ons
Once the software is running, you may want to install additional components - known as add-ons - that enhance
the rich set of features already available in Eikon. Follow these steps to install add-ons.
1.

Click the orange Eikon symbol (opposite), then choose the Help > About Refinitiv Eikon option.

2.

In the About window that opens, click ADD-ONS.

3.

Select the add-ons for which you have permission and click Install Selected.

Automatic update process
Eikon automatically installs updates in the background. These updates take effect when you close Eikon Desktop
and Microsoft Office, then restart them.
To make sure that all updates are applied, reboot your PC frequently, for example, once a week.

Uninstalling Eikon
In the Start > All Programs menu, choose Refinitiv > Tools > Uninstall Product.

Getting assistance with installations and updates
If you have verified that you meet all the requirements before installation and it is still not successful, this section
explains how to gather all the information you may need to provide to a support agent.

Saving the results of the requirements test
Eikon tests your hardware and software at installation automatically. However, if installation fails, you can run the
tests again and save the results, which you can then forward to Support. To save the results of the tests, follow
the steps below:
1.

Go to the Eikon website:
o

o
2.

https://eikon.refinitiv.com/ or
For private network users only, http://eikon.extranet.refinitiv.biz/

Make sure that your hardware and software meet the requirements to run Eikon.
a.

Click System and Network Test .

b.

Save the results of the test.
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Generating log files
Eikon can record its activities in a file, known as a log file. A Support Agent may ask you to send a log file to
identify and correct any difficulties you are experiencing.
To generate and save log files, follow the
steps below:
1.

In the Start > All Programs menu,
choose Refinitiv > Configuration
Manager.

2.

Go to the Logs tab.

3.

Following the Support Agent’s
instructions:

4.

a.

select trace and logging level
options

b.

choose directory where the log
file is to be stored

Click the Configure button.
 Logs will only be saved after you
restart Eikon.

Viewing additional information about my installation
When you request assistance, the support agent may ask you for information about your installation. Follow this
procedure to retrieve those details.
1.

Click the orange Eikon symbol (opposite), then choose the Help > About Refinitiv Eikon option.

2.

Click Copy to Clipboard, then paste the content into a text file or word processing document.

3.

Save the file to send it to support.

Requesting more assistance
Follow these steps to get assistance from the Eikon support team.
1.

Click the Contact Us link on the Eikon website.

2.

Attach these files with your request for assistance:
a.

the results of the test you ran in Saving the results of the requirements test.

b.

the log files you generated in Generating log files.

c.

the text from the About window you saved in Viewing additional information about my installation.
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Appendix A: Datastream apps in Eikon for
Microsoft Office
Installing Datastream apps
The Datastream apps in Eikon for Microsoft Office are optional add-ins, available to Eikon users who have
Datastream included in their subscriptions. The apps install the latest versions of Datastream For Office (DFO)
and Datastream Charting.
The key benefits of these apps revolve around improved deployment and integration with Eikon.

Minimum requirements
To install and run Datastream apps in Eikon for Microsoft Office, you must meet these minimum requirements:
•

You must have a valid Eikon subscription which includes Datastream. Your Eikon user ID also needs to have
been mapped on our servers to the associated Datastream ID to control data permissions and access to
saved lists, shared charts and expressions, and so on.
 If your package does not currently include Datastream, please contact your Account Manager or Support.

•

Administrator rights are not required for the DFO and Datastream Charting Apps. However, administrator
rights are required if previous versions of the DFO and Datastream Charting add-ins are already installed for
the uninstall process to be fully completed.
 Visual Studio Tools for Office (VSTO) and .Net 4.0 full profile (rather than client profile) are not required.

Enabling the Datastream Apps
The first stage is to enable the Datastream Apps
in the Refinitiv Eikon for Microsoft Office
Options dialog window. To do this, follow these
steps:
1.

Open Microsoft Excel.

2.

Click the Refinitiv Eikon ribbon, then click
Sign-in and sign into Refinitiv Eikon for
Microsoft Office.

3.

Click Add-Ons on the Refinitiv Eikon
ribbon.
The Options dialog box appears.

4.

Click the Enable buttons for the Datastream
( DFO) and Datastream Charting items.

5.

When prompted, close and restart Microsoft
Excel, PowerPoint, and Word.
 Once Datastream Apps have been installed, you can uninstall them by clicking Disable in the Options
dialog window.
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Datastream ribbons
When the Datastream Apps are enabled:
•

In Microsoft Excel, a Refinitiv Eikon Datastream ribbon appears
next to the Refinitiv Eikon ribbon.

•

In Microsoft Word and PowerPoint, a Refinitiv ribbon appears.
 If the Refinitiv ribbon does not appear in Word and PowerPoint,
see Troubleshooting the Refinitiv ribbon.

Troubleshooting the Refinitiv ribbon
If the Refinitiv ribbon does not appear in Microsoft Word and PowerPoint, follow these steps:
1.

In Microsoft Excel, go to the Refinitiv ribbon and click Settings.

2.

In the Settings dialog window, open the Sign in tab.

3.

Make sure that the Disable Refinitiv Eikon - Microsoft Office in Microsoft Word and Microsoft
PowerPoint check box is not selected.

Checking Datastream apps are working correctly in Excel
Follow these steps to download Datastream data in Microsoft Excel:
1.

In Excel, to login or connect, go to the Refinitiv ribbon and click the Online button.

2.

On the Refinitiv Eikon Datastream ribbon, make sure that the buttons on the ribbon are all active.
 When the Refinitiv ribbon is offline/logged out, the left-hand side of the Refinitiv Eikon Datastream
ribbon appears dimmed.

3.

On the Refinitiv Eikon Datastream ribbon, click Static Request.

4.

Type Microsoft in the Series/List field.

5.

Click Submit to confirm that the request successfully returns a value.

Checking Datastream Apps are working correctly in PowerPoint
Follow these steps to export a Datastream Chart to Microsoft PowerPoint:
1.

In PowerPoint, open a new presentation and go to the Refinitiv ribbon.

2.

Click Library.

3.

Go to the folder Datastream > Charts from Lipper Alpha Insights > Chart Of The Week, then select the
checkbox in the rightmost column to select a chart of your choice.

4.

Click the PowerPoint icon on the toolbar (directly above the list of charts) to open the Export Settings
window.

5.

Click the Export Chart button at the bottom of the window to export to the current slide.

6.

Once the chart has been exported, click the Refresh Charts button on the Refinitiv ribbon to refresh it.

Note: Repeat the above steps in Word to make sure that it is working correctly,
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Appendix B: Troubleshooting
In this section
•
•
•
•
•
•
•
•
•
•
•

How can I ensure my PC is ready to install Eikon?
What can I do if I receive alert messages?
What can I do if I receive failed messages and the installation stops?
What are the required settings for Internet Explorer?
What is the download policy for Refinitiv files?
Which authentication proxies can I use with Eikon?
How do i contact Refinitiv?
What does the support team need to know?
How do I activate log files?
Where can I find the log files?
How do I increase the level of detail in my log files?

How can I ensure my
PC is ready to install
Eikon?
To verify the system requirements before
installing Eikon you can run System Test
from the Product pages.
1.

2.

Open a browser and in the address bar
enter:
o

https://eikon.refinitiv.com/ or

o

For private network users only,
https://eikon.extranet.refinitiv.biz/

In the section System and Network
Test, click Run the Test.

EikonSystemTest.exe is downloaded to your local drive.
3.

Click Run or Open.

4.

System Test opens.

5.

Choose your Country, then select the test type options, and
click Start Test.
System Test runs the prerequisites tests and displays the
summary of passed, failed or warning results.

What can I do if I receive alert messages?
If you receive alert messages during the System Test, filter the results by clicking Alert and copy the
results to your clipboard. Or you can click the question mark icon and it will redirect to Eikon Help page.
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What can I do if I receive failed messages and the installation
stops?
To prevent additional problems, when certain prerequisites are not met, the installation stops. You must correct
these issues and then restart the installation.
When any of the following System Tests fail, they block the installation:
•

Browser Version

•

Browser JavaScript

•

Color Depth

•

Free Disk Space

•

HTTPS Connection Check

•

Legacy Thomson Reuters Products

•

Microsoft Excel Version

•

MSXML 3.0 Version

•

Operating System

•

Service Pack

•

Visual Basic for Applications

•

.NET Framework 4

You can find information about how to solve these issues by clicking and it redirects you to the Eikon Help page.

What are the required settings for Internet Explorer?
To prevent performance problems in Eikon, certain settings should be applied in
Internet Explorer. This section covers all settings required:

1

To access Internet settings:
1.

Open Control Panel > Network and Internet > Internet Options.

2.

Select the Advanced tab  and modify the settings.

3.

Click Apply  to accept your changes, then OK to close the window.

2

HTTP 1.1 settings
•

Enable Use HTTP 1.1

•

Enable Use HTTP 1.1 through proxy connections

Security settings
•

Clear Do not save encrypted pages to disk

•

Clear Use SSL 3.0

•

Enable Use TLS 1.0

•

Enable Use TLS 1.1

•

Enable Use TLS 1.2
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Certificate revocation settings
•

Disable Check for publisher’s certificate revocation

•

Disable for Check for server certificate revocation

•

Disable for Check for signatures on downloaded programs

ActiveX settings
Open Control Panel and navigate to Network and Internet > Internet Options >
Security tab > Internet > Custom level
•

Enable Run ActiveX controls and plug-ins

•

Enable Script ActiveX controls marked safe for scripting

Temporary Internet files settings
Open Control Panel and navigate to Network and Internet > Internet Options >
General tab. In the Browsing History section:
•

Click Settings

•

Set Disk space to use to 250MB (minimum) and click OK

•

Under the Advanced tab, clear Empty Temporary Internet Files folder when
browser is closed.

•

Clear Delete browsing history on exit.

WPAD settings
Open Control Panel and navigate to Network and Internet > Internet Options >
Connections tab
•

Click LAN Settings.

•

In the Local Area Network (LAN) Settings dialog box, ensure that Automatically
detect settings is not enabled.

Note: Even though Eikon supports WPAD, it is still recommended that Automatically
detect settings is disabled.

What is the download policy for Refinitiv files?
The Eikon installation packages are .exe and .eik (7zip) file format. These files are virus-checked and signed by
Refinitiv before they are published to the Update Service. Your site (or workstation) firewall must be set up to
allow the download of these packages.
List of servers and files to allow
Your firewall must allow the following servers to download .exe and .eik files through the HTTP protocol:
Domain

Download

https://eikon.refinitiv.com/ or for private network users only,
https://eikon.extranet.refinitiv.biz/

For installation bootstrap, System Test
standalone over Internet
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Domain

Download

*.download.cp.thomsonreuters.net

3

For Eikon packages on Update Service and
Eikon Apps (.kpak)

*.download.cp.thomsonreuters.com
*.download.cp.extranet.thomsonreuters.biz

Which authentication proxies can I use with Eikon?
Thomson Reuters Eikon is qualified with the following authentication proxies:
Proxy

Authentication Method

Apache

Basic

Squid

Basic

Microsoft ISA

Integrated (NTLM/Kerberos)

Microsoft Fore Front

Integrated (NTLM/Kerberos)

How do I contact Refinitiv?
You can contact Refinitiv at any time. Here are several ways to do it:
If

Contact

Eikon is not installed

•

Eikon Account Manager

•

https://eikon.refinitiv.com/ or http://eikon.extranet.refinitiv.biz/ and click Contact Us

•

Click Contact Us in the Sign in dialog box

•

Fill out the Contact Us page, and click Submit

•

Help > Contact Us

•

Press F1 and click Contact Us

•

From the Help window, choose Contact Us. Choose the method of contact, for
example, online or phone, fill in the details, and click Send.

You cannot sign in to Eikon

You encounter problems
when you running Eikon

What does the support team need to know?
When you call the support team, they may ask you certain questions about your Eikon configuration and your
machine set-up.

Identifying the delivery method
In Eikon, choose Helios > Help > About Refinitiv Eikon to identify your delivery method.

Remote access
The support teams often use Bomgar to access machines running Eikon. It is useful to let them know whether this
is possible on your machine.

3

These domains are to be rebranded to cdn.refinitiv.net, cdn.refinitiv.com, and cdn.extranet.refinitiv.biz. For further information
regarding domain rebranding, see Product Change Notification 11803 – Refinitiv domains.
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Local IT team details
If you have a local IT team at your site, you should have the name of your contact available.

How do I activate log files?
The support team may ask you to send log files to enable them to investigate your problem more easily. You can
activate logging by doing the following:
•

Navigate to Configuration Manager > Logs

•

Activate Configure Logs on the Workstation. The log options are now active and you can select further
tracing or logging options.

•

In Logs Path, enter the path to save the log files. If you do not enter a path or browse for one, the logs are
stored in the default location.

Where can I find the log files?
If you did not modify the path in Configuration Manager > Logs Path, the default path is used. The default path
depends on the user security group.
For administrators (per machine)

%AllUsersProfile%\Thomson Reuters\Eikon Data\Logs

For standard users (per user)

%UserProfile%\AppData\Local\Thomson Reuters\Logs

How do I increase the level of detail in my log files?
You can choose the level of logging you require in Configuration Manager > Logs, then select Configure Logs
on the Workstation. If you are experiencing issues with Eikon, it is useful to temporarily log more details.
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